แจ้งเตือน อุปกรณ์เน็ตเวิร์ค Zyxel มีบัญชีสิทธิ์ระดับสูงฝังไว้ เปิดทางแฮกเกอร์เข้ายึดอุปกรณ์ ควรรีบแพตช์

เมื่อเดือนธันวาคมที่ผ่านมาทาง Zyxel ได้ออกแพตช์เฟิร์มแวร์อุปกรณ์เน็ตเวิร์คในกลุ่มไฟร์วอลล์และ Access Point controller หลังนักวิจัยพบว่าเฟิร์มแวร์เวอร์ชั่น 4.60 มีบัญชีผู้ใช้ zyfwp พร้อมรหัสผ่านแบบ hardcode ทำให้แฮกเกอร์สามารถล็อกอินเข้าไปยังอุปกรณ์ หากเปิดบริการ Secure Shell หรือเว็บอินเทอร์เฟซให้เข้าจากภายนอก

Niels Teusink นักวิจัยที่เปิดเผยช่องโหว่นี้ระบุว่าเฟิร์มแวร์เวอร์ชั่นก่อนๆ ก็มีบัญชีผู้ใช้ zyfwp นี้อยู่ในระบบแต่ไม่ได้ตั้งรหัสผ่านเอาไว้ ทำให้ใช้ล็อกอินไม่ได้ แต่ทาง Zyxel กลับไปตั้งรหัสผ่านในเวอร์ชั่นหลังๆ และรหัสผ่านนี้เหมือนกันทุกอุปกรณ์

ความน่ากังวลของช่องโหว่นี้คือองค์กรจำนวนหนึ่งใช้ไฟร์วอลล์ Zyxel ทำหน้าที่เกตเวย์ VPN ให้องค์กรและ SSL VPN ก็ใช้พอร์ตเดียวกับเว็บอินเทอร์เฟซทำให้หลายองค์กรเปิดหน้าเว็บอินเทอร์เฟซออกสู่อินเทอร์เน็ตไปพร้อมกัน ล่าสุดทางบริษัท GreyNoise รายงานออกมาว่าเริ่มเห็นระบบโจมตีอัตโนมัติพยายามล็อกอินบัญชีนี้เพื่อทดสอบว่ามีไฟร์วอลล์ที่มีช่องโหว่เปิดสู่อินเทอร์เน็ตไว้หรือไม่

สำหรับผู้ใช้เฟิร์มแวร์เวอร์ชั่นเก่ากว่า 4.60 ไม่ได้รับผลกระทบจากช่องโหว่นี้แต่ก็มีช่องโหว่อื่นๆ น่ากังวลไม่แพ้กัน ดังนั้นควรเร่งอัพเดตแพตช์ล่าสุดเสมอ

ที่มา – ArsTechnica

No Description

Topics: 
Zyxel
Security